Documentation

Differences for HomePage

Differences between 2011-03-02 05:58:27 and 2011-10-12 06:12:54 (latest).

Documentation du logiciel libre ProfDepanne-2.6
Documentation du logiciel libre ProfDepanne-3.0

	Présentation :

Hébergement du projet : http://www.codingteam.net/project/profdepanne
Site du projet : http://andre-ani.fr/category/profdepanne/
Mainteneur : ANDRE Ani
Contact : contact@andre-ani.fr

	Le but de ce logiciel est d'aider les utilisateurs de l'outil informatique à résoudre eux-mêmes les problèmes communs que l'on peut rencontrer. Il fournit des pistes, en répondant à certaines questions.
	Il donne également de nombreuses informations sur le système, et sur l'utilisation d'un ordinateur en général, que se soit sous GNU/Linux ou sous Windows.
Il donne également de nombreuses informations sur le système, et sur l'utilisation d'un ordinateur en général, que se soit sous Gnu/Linux ou sous Windows.
	Il apporte également de l'aide pour migrer correctement vers un système GNU/Linux, et donne les bases de l'utilisation de ce système.
Il apporte également de l'aide pour migrer correctement vers un système Gnu/Linux, et donne les bases de l'installation et de l'utilisation de ce système.


	Fonctionnement :

	Il suffit de double-cliquer sur l'exécutable pour lancer l'installeur, puis de se laisser guider dans les étapes de l'installation.
	Que se soit sous Gnu/Linux ou Windows, il suffit de double-cliquer sur l'exécutable pour le lancer. Sous Gnu/linux, on peut le lancer en ligne de commande en tapant ./ProfDepanne dans une console.

	Il requiert l'installation de Java (OpenJDK : http://openjdk.java.net/), ou celui-ci :
	ProfDepanne se présente comme ceci, une fenêtre avec 4 onglets principaux, contenant divers sous onglets, chacun apportant différentes informations et questionnaires :
http://www.java.com/fr/download/

Sous Windows, il suffit de double-cliquer sur l'exécutable ProfDepanne.jar.
Sous GNU/Linux, un double clic sur ProFdepanne.jar marche également. Sinon, placez-vous dans le répertoire du logiciel puis, dans une console, tapez :
java -jar ProfDepanne.jar

	ProfDepanne se présente comme ceci, une fenêtre avec 5 onglets principaux, contenant divers sous onglets, chacun apportant différentes informations et questionnaires :
	Dans le menu Fichier, le sous menu Quitter (Ctrl + q) permet de fermer le programme.

	Dans le menu Fichier, le sous menu Sauvegarde permet d'enregistrer des informations sur le système dans un fichier texte (systeme.txt), dans le répertoire de ProfDepanne.
	Le menu Style permet de changer le Look and Feel de l'application, s'il est disponible sur le système hôte bien sur.

	Le menu Apparence permet de changer le Look and Feel de l'application, s'il est disponible sur le système hôte bien sur.
	Le menu Cours contient divers tutoriaux et documents sur l'informatique et sur Gnu/Linux.

	Le menu A Propos permet de se rendre sur le site de l'auteur, de lui écrire, d'afficher la fenêtre A Propos, et de télécharger la nouvelle version s'il y en a une de disponible.
	Le menu A Propos permet de se rendre sur le site de l'auteur (Ctrl + w), d'afficher la fenêtre A Propos (Ctrl + p), de vérifier s'il existe une nouvelle version et de la télécharger (Ctrl + m).

Ensuite, il y a divers onglets et sous onglets.
	Le menu Aide permet d'afficher cette documentation ainsi que le readme.

	Dans chaque questionnaires, à tout moment, vous pouvez taper «retour» dans la zone de saisie puis cliquez sur «suivant» pour revenir à la première question.
Puis viennent des onglets et sous onglets.


Onglet Dépannage :

Son. Permet d'abord de tester le son en lisant un petit fichier. On peut répondre à plusieurs questions pour tenter de résoudre un problème. On répond à l'aide des solutions proposées, puis on clique sur Suivant.
Dans chaque questionnaires, à tout moment, vous pouvez taper «retour» dans la zone de saisie puis cliquer sur «suivant» pour revenir à la première question.

Son. On peut répondre à plusieurs questions pour tenter de résoudre un problème. On répond à l'aide des solutions proposées, puis on clique sur Suivant.

Affichage. Permet de tester la 3D, uniquement pour GNU/Linux, et il y a également des questions.

Lenteur. Des questions pour résoudre les problèmes liés à la vitesse d'exécution du système et des programmes.
Affichage. Permet de tester la 3D, uniquement pour GNU/Linux, et il y a également des questions.

Système. Des questions pour résoudre les problèmes liés à la vitesse d'exécution du système et des programmes.

Réseau. En plus des questions, on peut tester son accès internet en mettant l'adresse complète d'un site dans la case indiquée et en cliquant sur le bouton «Aller à». On peut avoir des informations sur son réseau avec la commande netstat, et aussi afficher une liste des principaux ports avec leur utilisation.

Réseau. En plus des questions, on peut tester son accès internet en mettant l'adresse complète d'un site dans la case indiquée et en cliquant sur le bouton «Aller à». On peut avoir des informations sur son réseau avec la commande netstat, et aussi afficher une liste des principaux ports avec leur utilisation.

Onglet Informations :

Informations GNU/Linux. Cet onglet permet de récolter différentes informations sur le système, simplement en cliquant sur les boutons (les processus actifs, les utilisateurs, le matériel, la configuration du réseau, l'usage disque, la version du noyau, les messages du système). Le résultat s'affiche, ainsi que la commande qui a été lancée.
Onglet Informations :

Informations Windows. Il y a des conseils quand à l'utilisation et la maintenance de windows.
Informations Gnu/Linux. (Fonctionne uniquement sous Gnu/Linux). Cet onglet permet de récolter différentes informations sur le système, simplement en cliquant sur les boutons (les processus actifs, le matériel, la configuration du réseau, l'usage disque, la version du noyau, les messages du système). Le résultat s'affiche, ainsi que la commande qui a été lancée.
Le bouton Rapport permet de générer un rapport de toutes ces informations, au format pdf, enregistré dans le dossier ProfDepanne-3.0.

Informations Windows. Il y a des conseils quand à l'utilisation et la maintenance de windows, et on peut afficher les variables d'environnement.

Onglet Outils :

Il permet d'accéder aux différents outils présent dans ProfDepanne : TEditor, VisImage, Capture, Lookup, Compress, Convert.
Onglet Outils :

Onglet Tutos :
Il permet d'accéder aux différents outils présent dans ProfDepanne : TEditor, VisImage, Capture, Lookup, Convert, Horloge.

Glossaire. Il s'agit d'un glossaire des principaux termes informatiques.
Extensions. Les principales extensions en informatique.

Il y a ensuite quelques tutos sur l'utilisation d'un système GNU/Linux : Migrations, Commandes, Débuter, Logiciels.
Onglet Prof :

Onglet Aide :
Permet de « discuter » avec un bot, très simple, pour s'informer sur le mouvement des logiciels libres, le projet GNU, le copyleft, les libertés d'un logiciel sous GPL, les différentes licences libres.

Il y a cette documentation, ainsi qu'un Readme.


	Le logiciel ProfDepanne est là pour aider les utilisateurs de base de l'informatique, afin qu'ils puissent apprendre grâce à lui. Il est là pour leur faciliter l'utilisation de cet outil qu'est l'ordinateur. Il est donc très simple d'utilisation.