Documentation

Differences for HomePage

Differences between 2010-09-05 06:47:40 and 2011-03-02 05:58:27 (latest).

Documentation du logiciel libre ProfDepanne-2.5
Documentation du logiciel libre ProfDepanne-2.6

	Présentation :

Hébergement du projet : http://www.codingteam.net/project/profdepanne
Site du projet : http://andre-ani.fr/category/profdepanne/
Mainteneur : ANDRE Ani,
Mainteneur : ANDRE Ani
Contact : contact@andre-ani.fr

	Le but de ce logiciel est d'aider les utilisateurs de l'outil informatique à résoudre eux-mêmes les problèmes communs que l'on peut rencontrer. Il fournit des pistes, en répondant à certaines questions.
	Il donne également de nombreuses informations sur le système, et sur l'utilisation d'un ordinateur en général, que se soit sous GNU/Linux ou sous Windows.
	Il apporte également de l'aide pour migrer correctement vers un système GNU/Linux, et donne les bases de l'utilisation de ce système.


	Fonctionnement :

	Il suffit de double-cliquer sur l'exécutable pour lancer l'installeur, puis de se laisser guider dans les étapes de l'installation.

	Il requiert l'installation de Java (OpenJDK : http://openjdk.java.net/), ou celui-ci :
http://www.java.com/fr/download/

Sous Windows, il suffit de double-cliquer sur l'exécutable ProfDepanne.jar.
Sous GNU/Linux, placez-vous dans le répertoire du logiciel puis, dans une console, tapez :
Sous GNU/Linux, un double clic sur ProFdepanne.jar marche également. Sinon, placez-vous dans le répertoire du logiciel puis, dans une console, tapez :
java -jar ProfDepanne.jar
	ProfDepanne se présente comme ceci, une fenêtre avec 4 onglets principaux, contenant divers sous onglets, chacun apportant différentes informations et questionnaires :

	ProfDepanne se présente comme ceci, une fenêtre avec 5 onglets principaux, contenant divers sous onglets, chacun apportant différentes informations et questionnaires :

	Dans le menu Fichier, le sous menu Sauvegarde permet d'enregistrer des informations sur le système dans un fichier texte (systeme.txt), dans le répertoire de ProfDepanne.

	Dans le menu Fichier, le sous menu Sauvegarde permet d'enregistrer des informations sur le système dans un fichier texte (systeme.txt), dans le répertoire de ProfDepanne.

	Le menu Apparence permet de changer le Look and Feel de l'application, s'il est disponible sur le système hôte bien sur.

	Le menu Outils permet de lancer divers petits outils : Capture,  Compress, Contacts, Convert, Horloge, Lookup, TEditor, VisImage.
	Le menu Apparence permet de changer le Look and Feel de l'application, s'il est disponible sur le système hôte bien sur.

	Le menu A Propos permet de se rendre sur le site de l'auteur, de lui écrire, et de télécharger la nouvelle version s'il y en a une de disponible.
	Le menu A Propos permet de se rendre sur le site de l'auteur, de lui écrire, d'afficher la fenêtre A Propos, et de télécharger la nouvelle version s'il y en a une de disponible.

Ensuite, il y a divers onglets et sous onglets.

	Dans chaque questionnaires, à tout moment, vous pouvez taper «retour» dans la zone de saisie puis cliquez sur «suivant» pour revenir à la première question.


Onglet Dépannage :

Son. Permet d'abord de tester le son en lisant un petit fichier. On peut répondre à plusieurs questions pour tenter de résoudre un problème. On répond à l'aide des solutions proposées, puis on clique sur Suivant.

Affichage. Permet de tester la 3D, uniquement pour GNU/Linux, et il y a également des questions.

Lenteur. Des questions pour résoudre les problèmes liés à la vitesse d'exécution du système et des programmes.

Réseau. En plus des questions, on peut tester son accès internet en mettant l'adresse complète d'un site dans la case indiquée et en cliquant sur le bouton «Aller à». On peut avoir des informations sur son réseau avec la commande netstat, et aussi afficher une liste des principaux ports avec leur utilisation.


Onglet Informations :

Informations GNU/Linux. Cet onglet permet de récolter différentes informations sur le système, simplement en cliquant sur les boutons (les processus actifs, les utilisateurs, le matériel, la configuration du réseau, l'usage disque, la version du noyau, les messages du système). Le résultat s'affiche, ainsi que la commande qui a été lancée.

Informations Windows. On peut afficher l'espace disque libre (il suffit de sélectionner un fichier sur la partition voulue), avoir différentes informations sur le système, et il y a des conseils quand à l'utilisation de windows.
Informations Windows. Il y a des conseils quand à l'utilisation et la maintenance de windows.


Onglet Outils :

Il permet d'accéder aux différents outils présent dans ProfDepanne : TEditor, VisImage, Capture, Lookup, Compress, Convert.

Onglet Tutos :

Il permet d'accéder aux différents outils présent dans ProfDepanne : TEditor, VisImage, Capture, Lookup, Compress, Convert.

Onglet Tutos :

Glossaire. Il s'agit d'un glossaire des principaux termes informatiques.

Onglet Tutos :

Glossaire. Il s'agit d'un glossaire des principaux termes informatiques.
Extensions. Les principales extensions en informatique.

Cours GNU/Linux. Cet onglet propose de petits cours qui sont là pour aider les gens qui le souhaiterait à migrer vers GNU/Linux. Il y a des conseils, une aide à l'installation, ainsi que les bases pour se servir de ce système.
Glossaire. Il s'agit d'un glossaire des principaux termes informatiques.
Extensions. Les principales extensions en informatique.

Il y a ensuite quelques tutos sur l'utilisation d'un système GNU/Linux : Migrations, Commandes, Débuter, Logiciels.

Onglet Aide :

Onglet Aide :

Il y a cette documentation, ainsi qu'un Readme.

Il y a cette documentation, ainsi qu'un Readme.



	Le logiciel ProfDepanne est là pour aider les utilisateurs de base de l'informatique, afin qu'ils puissent apprendre grâce à lui. Il est là pour leur faciliter l'utilisation de cet outil qu'est l'ordinateur. Il est donc très simple d'utilisation.
	Son autre but est d'encourager et de faciliter la migration vers un système libre GNU/Linux. C'est pourquoi il y a quelques petits cours et informations sur ce système, ainsi qu'une aide à l'installation.

Pour toutes questions, commentaires, suggestions, bugs, critiques écrire à contact@andre-ani.fr



Documentation publiée sous licence libre GNU Free Documentation Licence (http://www.gnu.org/copyleft/fdl.html).


<code=text></code>